EML אנלייזר
מנתח הודעות EML כדי לחלץ כותרות, חלקי MIME, צירופים ומטא-נתונים למפתחים, אנליסטים אבטחה וצוותי IT.
Build Your Own Custom Web Calculator in Seconds
Type what tool or calculator you need below. Our AI will build it instantly for your site.
אודות כלי זה
הלוגיקה העיקרית כוללת בניית MIME לפי RFC 5322, נורמליזציה של כותרות, זיהוי From/To/Subject/Date, Message-ID ורמיזותAuthentification (DKIM/SPF/DMARC). התוצאה מכילה גם Content-Type, Transfer-Encoding ו-Charset, יחד עם תקציר מובנה: מילונים של כותרות, חלקי גוף ومטadata צירופים. פונקציות נדרשות: קבלת קובץ או טקסט EML גולמי, תמיכת multipart, סובלנות לנתונים חלקיים ולפגיעה קלה, ותוצרdeterministic. פונקציות מתקדמות (אופציונליות): זיהוי החלק המרכזי של הגוף, הבחנה בין תוכן Inline ו-attachments, פענוח encodings נפוצים, ועריכת שדות רגישים לשיתוף בטוח. ביצועים: decoding בזרימה עבור קבצים גדולים ושימוש זיכרון בטוח.
Inputs ו-Outputs: כולל קובץ EML או מחרוזת EML גולמית, דגלים אופציונליים להכללת חלקים בינאריים, פענוח מילים מוצפנות וגודל מקסימלי שלAttachments. Output מספק תקציר JSON עם Headers, מטה-נתונים, טקסטי גוף, צירופים ופרטי encoding.
אלגוריתמים וחישובים: בניית עץ MIME, פענוח header RFC2047, decoding Base64/Quoted-Printable, זיהוי גבולות ובחירת חלק הגוף. נספרים צירופים וחלקים ונסמנים חריגות. אין קריאות לאשררים חיצוניים או decrypt.
טיפול בטעויות: כניסות לא תקינות, קריאות חלקיות וגבולות שבורים עם fallbacks בטוחים. הערות התאמה לאזור: שימוש בבייטים ותאריכים ISO; אפשרויות redaction ופרטיות זמינות. הנחות: כניסה RFC822-like; החרגות: גישה ישירה לתיבה, decryption או אינדקס תיבות דוא"ל.
איך להשתמש
הזן קלט: העלה קובץ EML או הדבק תוכן EML גולמי.
בחר אפשרויות: הגדר את גודל הקובץ המוגבל של הצירוף, החלט אם לפענח מילים מקודדות ואם לכלול חלקים בינאריים.
הרץ ניתוח: התחל את הניתוח כדי ליצור סיכום JSON מובנה.
סקור פלט: בדוק כותרות, חלקי גוף וצירופים; ייצא את הדוח אם נדרש.
Frequently Asked Questions
מצא תשובות מהירות
מהו קובץ EML?
איך נעזר המערכת בקבצים גדולים?
האם הוא יכול לפענח headers ו-MIME-parts מוצפנים?
האם האנליזה שמורה לפרטיות?
Need to run multiple calculations?
Create a free account today to unlock unlimited daily runs, access advanced parameters, save your history, and request custom features.
Related Tools
Other useful calculators and utilities you might like
ממיר Spotify ל-MP3
ממיר קבצי שמע מסופקים מקומית ל-MP3, מאפשר האזנה offline ותאימות בין מכשירים למוזיקה בבעלות חוקית ואח...
מחשב מרחק דרך
מחשב מרחק דרך למטיילים, מתכנני לוגיסטיקה ונהגים כדי להעריך במהירות מרחקים וזמן בין מקומות.
המשוב שלך חשוב
עזור לנו לשפר
Norwegian
Danish
German
English
Spanish
French
Italian
Dutch
Portuguese
Swedish
Hebrew
Arabic